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Introduction 
This user guide describes how to use GanttProject, which is a project management software application. 
You can use it to create a schedule of tasks, assign resources to them, and track the progress of a 
project. GanttProject is similar to Microsoft Project but has fewer features and is simpler. Also, it is 
open-source software and has been in existence since 2003. 
 

What’s new 
New GanttProject features and enhancements are summarized in the following table. 
  

GanttProject 
Release 

 
Description 

2.8 The use of all functionality in this release is 
described in the first version of this guide. 

 

Feedback 
If you have comments on this document, please send them to santos.r@husky.neu.edu. 
 

Get started 
To start using GanttProject, you first need to download and install it. Then, to quickly get oriented with 
it, it helps to understand the overall layout of the task and resource screens, which are the two main 
screens and are similar. Lastly, before starting to use GanttProject, it helps to understand the main steps 
needed to create a project in it. 
 

Downloading and installing GanttProject 
Before you can use GanttProject, you first need to download and install it and the Java Runtime 
Environment (JRE), which it requires. 
 
To download and install GanttProject and JRE 

1. Go to www.ganttproject.biz. 
2. Select the large Download new button. 

 

3. For option one, select an operating system, or, for option two, select the Free Download link. 
4. Follow the on-screen instructions to download the installation software, which will be in an 

executable file with a .exe extension. 
5. GanttProject requires the Java Runtime Environment (JRE). If you do not have JRE on your 

device, then download and install it by doing the following: 
a. Select the provided Java link on the GanttProject webpage. 
b. At the Java site, follow the on-screen instructions to download the JRE software, which 

will be in an executable file with a .exe extension. 

mailto:santos.r@husky.neu.edu
http://www.ganttproject.biz/
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c. Run the downloaded JRE software by double-clicking it. 
d. Follow the instructions in the Java Setup screens. 

6. Run the downloaded GanttProject installation software by double-clicking it. 
7. Follow the instructions in the setup wizard. 

 

Screen layout 
Figure 1 and 2 below show example screenshots of the tasks in a project and the associated resources in 
that project, respectively. Many display options are available for these screens, especially for tasks, so 
you can change the information displayed in them. These two screenshots are from the project in the 
file HouseBuildingSample.gan. This file is in the folder named GanttProject-X.Y, which is named after a 
specific version of GanttProject and is created when GanttProject is installed. You may want to open this 
file to learn more about the ways GanttProject can be used to schedule and track a project. 
 
Both screenshots in the figures contain a panel on the left for the tasks or resources in the project and a 
corresponding chart in the area on the right. This house building project runs for about 20 weeks, but 
only the first 7 weeks are shown in the charts. Some additional explanatory information is provided in 
the callouts on the screenshots. 
 

 
 

Figure 1 Tasks in a Project 

Milestone 
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Figure 2 Resources in a Project 
 

Overview of creating a project and adding tasks and 
resources 
The recommended main steps for creating a project and adding tasks and resources to it are presented 
here. Note that resources are typically used for people who complete tasks but could be for things, such 
as equipment or materials, that are needed for tasks. 
 

1. Project: Create a project, as described in To create a project. 

2. Resource roles: If you want to assign roles, such as developer and tester, to resources, then first 
add them to the project, as described in To add resource roles. 

3. Resources: If you want to assign resources to tasks, then add resources, as described in To add a 
resource. 

4. Tasks: Add tasks, as described in To create a task. You can create links between tasks when you 
create them or afterward in the following step. 

Resource 
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resource is 
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Tasks for 
resource 



Projects  7 
 

 

  

GanttProject User Guide  Release 2.8 

5. Links: If you did not add all needed links in the previous step, then link tasks, as described in To 
link tasks. 

 

Projects 
Before creating a task schedule and associated needed resources, you first create a project that will 
contain them. In a project, you can also create resource roles, such as developer and tester, which you 
can assign to resources. Also, you can create a calendar of holidays and nonwork days. After creating a 
project, you then save this information in a project file. 
 

Creating a project 
You can create a project that contains the name of the project, resource roles, which you can assign to 
resources, and a calendar of holidays and nonwork days. Later you can add tasks and associated 
resources to the project. 
 
To create a project 

1. Select Project > New or Ctrl+N. 
2. In the dialog box, enter a name for the project and other information as needed. 
3. Select Next. 
4. (Optional) Select from available role sets to add the included roles to the project. You can hover 

over a role set to see the included roles. 
5. Select Next. 
6. Configure holidays and nonwork days for the project as needed. 

✓ Tip: You can also import a holiday calendar, as described in To import a holiday calendar 
in an iCalendar file. 

7. Select OK. 
 

Changing project properties 
You can change a project’s name and various items used in a project. This includes resource roles, such 
as developer and tester, and a calendar of holidays and nonwork days. 
 
To change project name and description 

1. Go to Project > Properties. 
2. Change the Name, Description, and other items as needed. 
3. Select OK. 

 
To change project calendar 

1. Go to Project > Properties. 
2. Go to the Calendar tab. 
3. Change information on nonwork days, including weekends and holidays, as needed. 

✓ Tip: You can also import a holiday calendar, as described in To import a holiday calendar 
in an iCalendar file. 

4. (Optional) Change the project start date. 
5. Select OK. 
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To add resource roles 

1. Go to Project > Properties. 
2. Go to the Resource roles tab. 
3. Select the row at the bottom that contains Type new role name here. 
4. Enter the name of the role, such as developer or tester, and then select the Enter key. To enter 

additional roles, repeat this step. 
5. Select OK. 

 
To delete resource roles 

1. Go to Project > Properties. 
2. Go to the Resource roles tab. 
3. Select the role that you want to delete. 

Warning: To avoid errors, do not attempt to simultaneously delete multiple roles. 

4. Select Delete. 
5. If you want to delete more roles, repeat the previous two steps. 
6. Select OK. 

 

Opening and saving a project 
You can open or save a project file in your file system. Project files are stored in GanttProject files, which 
have a .gan suffix, or XML files, which have a .xml suffix. 
 
To open a project 

• Go to Project > Open. 
 
To save a project 

• Select Project > Save or Project > Save As. 
 

Resources 
Resources are typically used for people who complete tasks but could be for things, such as equipment 
or materials, that are needed for tasks. You can create resources and roles for them, such as developer 
and tester. Later, when you create tasks, you can assign these resources to them. 
 

Resource roles 
You can create resource roles, such as developer and tester, and then assign these roles to resources. 
These roles are maintained in a project’s Properties. For information on adding and deleting resource 
roles, see the subsections on roles in Changing project properties. 
 

Adding, modifying, deleting, and e-mailing a resource 
You can add, modify, and delete resources. Also, you can initiate the creation of an e-mail message to a 
resource from within GanttProject. 
 
To add a resource 

1. Go to the Resources Chart tab. 
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2. Do one of the following: 

• Select New Resource , Ctrl+H, or Resources > New Resource. 
• Right-click in the resource panel and then select New Resource. 

3. Enter the name of the resource. 
4. Enter other information as needed, including for the following: 

• Default role: Select a role for the resource. 

Note: For information on adding roles to a project, see To add resource roles. 

• Standard rate: Enter a daily pay rate for the resource. A currency value is not defined, 
and it is recommended that you consistently use the same currency in a project. 

Note: The calculated cost of a task, which is partially based on the rates of 
resources, is displayed in the Properties for a task in the Resources tab. 

5. (Optional) To enter days that the resource will be unavailable, select and then populate the 
Days off tab. 

6. (Optional) To create custom columns that will be displayed in the resource panel, go to the 
Custom Columns tab and then do the following: 

a. Select Manage columns. 
b. Select Add. 
c. Enter the name of the column and then select the Enter key. 
d. (Optional) Change the Column type and enter a Default value. 
e. (Optional) Add more columns by repeating the previous three steps. 
f. Select OK. 

7. Select OK to complete the addition of the resource. 

8. (Optional) To move the new resource up in the list of resources, select Move resource up  in 
the upper left part of the resource panel. 

 
To modify a resource 

1. Go to the Resources Chart tab. 
2. Double-click the resource that needs to be modified. 
3. Change the contact information, role, pay rate, days off, and other information as needed. 
4. Select OK. 

 
To delete a resource 

1. Go to the Resources Chart tab. 
2. Select the resource to delete. 

3. Select Delete resource  or the Delete key. 

Warning: There is not a confirmation step for this delete operation. However, if a 

resource is accidentally deleted, you can restore it by selecting Undo . 
 
To e-mail a resource 

1. Go to the Resources Chart tab. 
2. Select the resource to e-mail. 
3. Right-click on the selected resource and select Send an e-mail. A message composition window 

will open using your default e-mail program. Note that the e-mail address used is taken from the 
Mail entry in the resource’s Properties. 
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Changing the listed order of a resource 
You may want to list the resources in the resource panel in a specific sequence, such as alphabetically, 
or group them based on roles. To do this, you can change the order of resources. 
 
To change the listed order of a resource 

1. Go to the Resources Chart tab. 
2. Select the resource to move. 

3. In the upper left part of the resource panel, select Move resource up  or Move resource 

down  as many times as needed. 
 

Tasks 
You can create and link tasks that you want to track in a project. Also, to organize tasks and better 
visualize projects that contain many tasks, you can create summary tasks that contain subtasks. 
Additionally, you can show the critical path through the tasks in a chart to see the tasks that determine 
when a project completes. You can also create baselined copies of a chart and then later display a 
comparison of one to a changed version of the chart, such as after some tasks are delayed.  
 

Creating a task 
When you create a task, you can select dates for it, such as for starting and completing the task, create 
links from other tasks, and select resources needed for the task. 
 
To create a task 

1. Go to the Gantt tab. 
2. If you want to create the task directly below an existing task in the task panel, select that task. 

Otherwise, the task will be created at the bottom of the current list of tasks. 
3. Do one of the following: 

• Select New task , Ctrl+T, or Tasks > New Task. 
• Right-click in the task panel or chart and select New task. 

4. Enter the name of the task and then select the Enter key. 

✓ Tip: If you select Alt+Enter here instead of Enter, you can skip the next step. 

5. Double-click the new task to open it. 
 

General tab: Enter dates and general task information 
6. Change values as needed, including for the following: 

• Milestone: Select if this task is a milestone task. A milestone task is displayed as a 
diamond in the task chart, and its name is displayed immediately above the milestone’s 
date on the timeline at the top of the task chart. Additionally, the Duration for a 
milestone is set to 1 and cannot be changed. Note that you may want to use a unique 
color for a milestone by using the Colors control, as described in this subsection on the 
General tab. 

• Scheduling options in this dialog box: Select this link to choose whether the Begin date, 
End date, or Duration is calculated. You enter values for the two items not calculated. 
Duration is in days. 
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• Earliest begin: Select if there is a restriction on the earliest date the task can start. Also, 
select the associated Copy begin date link to use the value of the task’s Begin date. 

• Priority: Select the priority of the task. The priority can be displayed as a small colored 
circle in the Priority column in the task panel. The priority colors are as follows: 

Priority Color Displayed in Priority Column 

Lowest and Low Green 

Normal Blue 

High and Highest Red 

For information on displaying the Priority column, see To show or hide task or resource 
columns. 

• Progress: Enter a value from 0 to 100 to indicate the percentage of the task that has 
been completed. In the task chart, a horizontal black bar is displayed inside the task, and 
the length of the bar corresponds to this percentage. 

• Show in timeline: Select to display the task name immediately above the task’s start 
date on the timeline at the top of the task chart. 

• Shape: To make a task appear unique, select a pattern to fill the task bar in the task 
chart. 

• Colors: To make a task appear unique, select the Choose link to set the color of the task 
in the chart. In this dialog box, multiple color models are available to specify a color, as 
indicated by the tab names. Select a color in one of the tabs and then select OK. 

7. Enter values in the remaining tabs or select OK if done. 
 

Predecessors tab: Create links from other tasks 
8. To create links from other tasks, go to the Predecessors tab. 
9. Select Add. 
10. Select the Task name of the predecessor or other task. 
11. Change other values as needed: 

• Type: To change the type of link, select the default value in the Type cell, and then 
select a link type from the list. The following types are available, and the descriptions 
are for the case when the Delay is at its default value of 0. 

Link Type Description 

Finish-Start The added task must finish at the same time or before the 
task being created starts. This is the default and is typical. 

Finish-Finish The added task must finish at the same or before the task 
being created finishes. 

Start-Finish The added task must start at the same time or before the 
task being created finishes. Note that this is rare. 

Start-Start The added task must start at the same time or before the 
task being created starts.  

• Delay: To change the delay (or lag time) between the added task and the task being 
created, double-click the default delay value and enter the number of days for the 
delay. This time can be a positive or negative value. A negative value can be used, for 
example, to have the task being created start a specified number of days before the 
added task finishes. 



Tasks  12 
 

 

  

GanttProject User Guide  Release 2.8 

• Link hardness: To change the amount of flexibility in the time between the tasks, select 
the default value in the Link hardness cell, and then select a value from the list. The 
following values are available: 

Link hardness Description 

Strong There is no flexibility in the time between tasks. For 
example, if the Type of link is Finish-Start and the Delay is 2 
days, then the task being created must start exactly 2 days 
after the added task finishes. Solid lines are used for Strong 
links in the task chart. 

Rubber There is flexibility in the time between tasks. For example, if 
the Type of link is Finish-Start and the Delay is 2 days, then 
the task being created can start 2 or more days after the 
added task finishes. This also means that the added task can 
finish 2 or more days before the start of the task being 
created. Dashed lines are used for Rubber links in the task 
chart. 

Note: The default value for Link hardness is configured in GanttProject’s 
settings, as described in To change Gantt chart settings. 

12. (Optional) Add more linked tasks by repeating the previous three steps. 
13. Enter values in the remaining tabs or select OK if done. 

 
Resources tab: Select resources needed for task 
14. To select resources needed for the task, go to the Resources tab. 
15. Select Add. 
16. Select the Resource name of the resource. 
17. Change other values as needed: 

• Unit: Enter the percentage of time that a resource, such as a person, will spend on the 
task. Note that if a value over 100 is entered, the resource will be displayed as 
overloaded in the resource chart. 

• Coordinator: Select if the resource is the coordinator for a task. This can be significant in 
cases in which multiple people are resources for a task. 

• Role: To change the role of the resource, select the default value in the Role cell, and 
then select a role from the list. 

Note: For information on adding roles to a project, see To add resource roles. 

• Task cost: Select the way the task cost is determined. The Calculated method displays a 
cost that is the sum of all the costs of the resources supporting the task. The cost of a 
resource is calculated using the following formula: 

Resource Cost = Task Duration × Resource Pay Rate × Percent of Resource Time 

The source of the terms used in this formula are as follows: 

Task Duration: The value of Duration, which is in days, is in the task’s General 
tab. 

Resource Pay Rate: The value of Standard rate is in the Properties of the 
resource. 
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Percent of Resource Time: The value of Unit is in this tab on Resources. 

A currency value is not defined for costs and resource rates, and it is recommended that 
you consistently use the same currency in a project. 

✓ Tip: You can display a Cost column in the task panel that contains costs for tasks. 
For more information, see To show or hide task or resource columns. 

18. (Optional) Add more resources by repeating the previous three steps. 
19. Enter values in the remaining tab or select OK if done. 

 
Custom Columns tab: Create custom task columns for task panel 
20. To create custom columns that will be displayed in the task panel, go to the Custom Columns 

tab. 
21. Select Manage columns. 
22. Select Add. 
23. Enter the name of the column and then select the Enter key. 
24. (Optional) Change the Column type and enter a Default value. 
25. (Optional) Add more columns by repeating the previous three steps. 
26. Select OK to complete the creation of the columns. 
27. Select OK to complete the creation of the task. 

 

Creating a summary task 
If you have a group of related tasks, you can create a summary task that contains them. A summary task 
can be expanded or collapsed in the task panel and can contain other summary tasks. Consequently, you 
can use summary tasks to organize and better visualize projects that contain many tasks. An example 
summary task that contains three subtasks is shown here. 
 

 
 

To create a summary task containing subtasks 
1. Go to the Gantt tab. 
2. Go to Tasks > New Task. 
3. Enter the name of the summary task and then select the Enter key. 
4. Do one of the following, depending on whether you prefer to drag subtasks to the summary task 

or select subtasks and indent them under the summary task. 
• Drag method: 

a. Select one or more tasks that you want to have as subtasks. Use and continue to 
hold Shift and click to select two or more consecutive rows, or use and continue 
to hold Shift, Ctrl, and click to select two or more non-consecutive rows. 

b. Drag the selected task or tasks to the summary task. 
• Indent method: 
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a. Select Move task up  as many times as needed until the summary task is right 
above the task or tasks that are to be subtasks. 

b. Select the task or tasks below the summary task that are to be subtasks. Use 
Shift and click to select two or more consecutive rows. 

c. In the upper left part of the task panel, select Indent . 
 

Modifying or deleting tasks 
You can modify a task or delete tasks. If you want to change the dates or duration of a task, then you 
need to consider if they are constrained by links to other tasks. If they are, you need to change the dates 
for the other tasks or change the Link hardness for links to Rubber. Link hardness is specified in a task’s 
Properties in the Predecessors tab. 
 
To reschedule a task or change its duration 

1. Go to the Gantt tab. 
2. Do one of the following, depending on whether you prefer to make the change in the task chart 

or task properties: 
• Task chart: Select Ctrl and drag the task to the left or right to reschedule it, or select the 

right edge of the task and drag it to the left or right to change its duration. 
• Task properties: 

a. Double-click the task that needs to change. 
b. Change the Begin date, End date, or Duration as needed. Note that as per the 

Scheduling options in this dialog box link, either Begin date, End date, or 
Duration is calculated based on values you enter for the other two. Duration is 
in days. 

c. Select OK. 
 
To change the resources needed for a task 

1. Go to the Gantt tab. 
2. Double-click the task that needs to change. 
3. Go to the Resources tab. 
4. Do one of the following, depending on whether you want to add, change, or delete a resource: 

• Add resource: 
a. Select Add. 
b. Select the Resource name of the resource. 
c. (Optional) Change other attributes as needed. For information on these 

attributes, see the subsection on the Resources tab in To create a task.  
• Change resource: 

a. In the row of the resource to change, select the resource in the Resource name 
cell, and then select a new resource. 

b. (Optional) Change other attributes as needed. For information on these 
attributes, see the subsection on the Resources tab in To create a task. 

• Delete resources: 
a. Select one or more resources. Use Shift and click to select two or more 

consecutive rows, or use Shift, Ctrl, and click to select two or more non-
consecutive rows. 

b. Select Delete. 
5. Select OK. 
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To change task properties 

1. Go to the Gantt tab. 
2. Double-click the task that needs to change. 
3. Change the priority, progress, predecessor links, and other information as needed. For 

information on the description of items in a task, see To create a task. 
4. Select OK. 

 
To delete tasks 

1. Go to the Gantt tab. 
2. Select the task or tasks to delete. Use Shift and click to select two or more consecutive rows, or 

use Shift, Ctrl, and click to select two or more non-consecutive rows. 

3. Select Delete task  or the Delete key. 
 

Changing the listed order of tasks 
To better organize tasks listed in the task panel, you can change their order. 
 
To change the listed order of tasks 

1. Go to the Gantt tab. 
2. Select the task or tasks to move. Use Shift and click to select two or more consecutive rows. 

3. In the upper left part of the task panel, select Move task up  or Move task down  as many 
times as needed. 

✓ Tip: To sort all tasks by date, select the column heading of Begin date or End date in the task 
panel. 

 

Linking and unlinking tasks 
You can link tasks by adding them to the Predecessors tab in a task’s Properties when you create a task, 
as described in To create a task. Also, you can link tasks after you have created them without using this 
tab, as described here. 
 
To link tasks 

1. Go to the Gantt tab. 
2. Do one of the following, depending on whether you prefer to create the link by drawing it in the 

task chart or selecting tasks in the task panel: 
• Task chart: Click on a task and drag the link arrow to another task. 
• Task panel: 

a. Select two or more tasks that are currently not linked to each other. Use Shift 
and click to select two or more consecutive rows, or use Shift, Ctrl, and click to 
select two or more non-consecutive rows. 

b. Select the link button  at the top of the task panel. 
 
To unlink tasks 

1. Go to the Gantt tab. 
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2. Select two or more tasks that are currently linked to each other. Use Shift and click to select two 
or more consecutive rows, or use Shift, Ctrl, and click to select two or more non-consecutive 
rows. 

3. Select the unlink button  at the top of the task panel. 
 

Displaying critical path through tasks 
You can display the critical path in a task chart, which shows the path through the linked tasks in it that 
takes the longest amount of time and determines when a project completes. This can help you 
understand which tasks are the most important, so you can work to ensure they complete on schedule 
so the project will complete on time. When a critical path is displayed in a task chart, tasks in the path 
are shown with a diagonal line pattern in them, as shown in the figure here. 
 

 
 
To show or hide the critical path through tasks 

1. Go to the Gantt tab. 
2. In the upper right of the window, select Show critical path or Hide critical path. 

 

Baselining task dates to see schedule changes 
You can create a baselined copy of a task chart, which contains the schedule for all tasks in the chart. 
Then, after changes are made to the schedule, such as after some tasks are delayed, you can display a 
comparison of the changed version of the chart with the baselined version of it. Also, you can create and 
save multiple baselined versions of a chart at different times throughout a project and then view a 
comparison of the current schedule with any one of the baselined versions. 
 
For example, Figure 3 below shows the original version of a schedule that was baselined. Figure 4 below 
it shows the schedule later after some changes were made. In Figure 4, for tasks that have changed, 
colored bars show them in their originally scheduled positions. Using default colors, green is used to 
indicate tasks that will complete earlier than originally scheduled, and red is used to indicate tasks that 
will complete later. 
 

 
Figure 3 Originally Baselined Schedule 
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Figure 4 Revised and Baselined Schedules 

 
To create a baseline of task dates 

1. Go to the Gantt tab. 
2. In the upper right of the window, select Baselines. 
3. Select Add and then enter the name of the baselined version. 
4. (Optional) Select one of the Choose links to change the bar color used in the display of the 

baselined version of the schedule. 
5. Select OK. 

Note: If you now make changes to the dates of a task, a colored bar below it in the task’s originally 
scheduled position is displayed. 

 
To delete a baseline of task dates 

1. Go to the Gantt tab. 
2. In the upper right of the window, select Baselines. 
3. Select the baseline version that you want to delete. 
4. Select Delete. 
5. Select OK. 

 
To show or hide baseline dates 

1. Go to the Gantt tab. 
2. In the upper right of the window, select Baselines. 
3. Do one of the following: 

• Show baseline: Select the baseline version that you want to display. 
• Hide baseline: Select Hide baselines. 

4. Select OK. 
 

Common operations 
You can perform common operations on tasks and resources, including searching, cutting, copying, 
pasting, undoing, redoing, and printing. 
 

Searching for a task or resource 
You can search for tasks and resources in a project using one of two methods. One method searches 
task and resource names and task notes, and the other searches text in the columns in the task or 
resource panel. 
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To search task and resource names and task notes 

1. In the upper right of the GanttProject window, enter a search term, and then select the Enter 
key. 

2. Do one of the following to complete the search: 
• Select a search result and then select Enter. 
• Double-click on a search result. 

 
To search columns in task or resource panel 

1. In the task or resource panel, select a task or resource. 
2. Select Ctrl+F. 
3. Enter a search term, and select search options as needed. 
4. Select Find as many times as needed. 
5. Select Close. 

 

Cutting, copying, and pasting tasks and resources 
You can cut, copy, and paste tasks or resources in the task or resource panel. 
 
To cut tasks or resources 

1. Select one or more rows in the task or resource panel. Use Shift and click to select two or more 
consecutive rows, or use Shift, Ctrl, and click to select two or more non-consecutive rows. 

2. Select Cut , Ctrl+X, or Edit > Cut. 
 
To copy tasks or resources 

1. Select one or more rows in the task or resource panel. Use Shift and click to select two or more 
consecutive rows, or use Shift, Ctrl, and click to select two or more non-consecutive rows. 

2. Select Copy , Ctrl+C, or Edit > Copy. 
 
To paste tasks 

1. Select a row in the task panel to specify the row after which tasks will be pasted. 

2. Select Paste , Ctrl+V, or Edit > Paste. 
 
To paste resources 

1. In the Resources Chart tab, select Paste , Ctrl+V, or Edit > Paste. Note that resources are 
pasted at the bottom of the resource panel. 

2. (Optional) To move a pasted resource up in the list of resources, select the resource and then 

select Move resource up  in the upper left part of the resource panel. 
 

Undoing and redoing operations 
You can undo and redo various operations, including deleting, cutting, and pasting. 
 
To undo an operation 

• Select Undo , Ctrl+Z, or Edit > Undo. 
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To redo an operation 

• Select Redo , Ctrl+Y, or Edit > Redo. 
 

Printing tasks and resources 
You can print the task or resource columns and associated chart in a project. 
 
To print a project’s tasks or resources 

1. Go to the Gantt or Resources Chart tab. 
2. Select Project > Print or Project > Print Preview. 
3. Select options and enter values as needed. 

4. Select the Print button, or, in the print preview window, select Print  in the upper left part of 
the window. 

 

Viewing GanttProject version, license, and software libraries 
You can view information on the GanttProject version and development team, the GanttProject 
software license, and the software libraries and versions used in GanttProject. 
 
To view GanttProject version, license, and software libraries 

1. Go to Help > About. 
2. Go to the Summary, License, or Libraries tab to view information on the GanttProject version 

and development team, the GanttProject software license, or the software libraries and versions 
used in GanttProject. 

3. Select OK. 
 

Workspace, FTP, and CSV settings 
You can change the workspace and various settings in GanttProject. This enables you to, for example, 
better view information in task and resource charts, change the columns displayed in the task and 
resource panels, and customize the user interface. Also, you can configure access settings for a File 
Transfer Protocol (FTP) server for exported files and configure the task and resource fields that are 
included in exported files that contain comma-separated values (CSV). 
 

Changing days visible in a task or resource chart 
To better view a task or resource chart, you can zoom in or out of it or go to a specific time in it, such as 
a specific day or week. 
 
To change days visible in a task or resource chart 

• Do one of the following, depending on whether you want to zoom in or out of a chart or go to a 
specific time, such as a day or week, in a chart: 

– Zoom chart: 
◦ Move the pointer to inside the chart, and then select Ctrl and rotate the mouse 

wheel. 
◦ Select Zoom In or Zoom Out in the upper left of the chart. 

– Go to a time in chart: 
◦ Drag the chart left or right. 
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◦ At the top of the chart, select a value from the list, which is in bold and has a 
default value of Today. 

◦ Select Past or Future in the upper right of the chart. 
 

Managing task and resource columns 
In the task and resource panels, you can change the columns displayed and even create new custom 
columns. 
 
To show or hide task or resource columns 

1. Right-click a task or resource column heading, such as Name, and select Manage columns. 
2. Select one or more column names. 
3. Select Show selected or Hide selected. 
4. Select OK. 

 
To create custom task or resource columns 

1. Right-click a task or resource column heading, such as Name, and select Manage columns. 
2. Select Add. 
3. Enter the name of the column and then select the Enter key. 
4. (Optional) Change the Column type and enter a Default value. 
5. (Optional) Add more columns by repeating the previous three steps. 
6. Select OK. 

 
To change the order of task or resource columns 

• Drag a task or resource column heading, such as Name, left or right to the desired position. 
 
To resize task or resource columns 

• Drag the vertical separator line between two task or resource columns to the desired position. 
 

User interface, chart, and other settings 
You can change multiple settings that GanttProject uses, including ones for the user interface and for 
task and resource charts. Also, you can configure access settings for a File Transfer Protocol (FTP) server 
for exported files and configure the task and resource fields that are included in exported files that 
contain comma-separated values (CSV). 
 

Customizing user interface 
You can change settings for the user interface, such as for fonts, language, and date format. Also, you 
can choose whether to get news on updates to GanttProject. 
 
To customize user interface 

1. Go to Edit > Settings. 
2. Change the settings as needed, including for the following: 

• Logo file: To change the logo file, specify the file that contains the desired logo. The logo 
is displayed in the user interface and in task and resource reports and print outs. Also, 
for reference, the default GanttProject logo is 1024 pixels wide and 47 pixels high. 

3. Select OK. 
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Changing chart settings 
For task charts, you can change multiple settings, including for default task names and information 
displayed near task bars in charts. For both task and resource charts, you can change the colors used for 
bars in them. 
 
To change Gantt chart settings 

1. Go to Edit > Settings. 
2. Go to the Gantt chart tab. 
3. Change the settings as needed, including for the following: 

 
Defaults section: Select task names, colors, and links 
• Name pattern for task copies: To change the default suffix used in the names of newly 

created tasks, enter a pattern for the suffix. 
• Link hardness: Select to change the default for the amount of flexibility in the time 

between linked tasks. The following values are available: 

Link hardness Description 

Strong There is no flexibility in the time between linked tasks. For 
example, if the Type of link is Finish-Start and the Delay is 2 
days, then a task must start exactly 2 days after a 
predecessor task finishes. Solid lines are used for Strong 
links in task charts. 

Rubber There is flexibility in the time between linked tasks. For 
example, if the Type of link is Finish-Start and the Delay is 2 
days, then a task can start 2 or more days after a 
predecessor task finishes. Dashed lines are used for Rubber 
links in task charts. 

 
Task details section: Select task bar display information 
• Above, Below, Left, and Right: To change information that is displayed near task bars in 

Gantt charts, select values for these attributes. 
4. Select OK. 

 
To change resource chart settings for bar colors 

1. Go to Edit > Settings. 
2. Go to the Resource chart tab. 
3. Change the colors as needed. 
4. Select OK. 

 

Configuring FTP server settings for file exports 
You can configure settings that GanttProject will use to access a File Transfer Protocol (FTP) server when 
you want to export files and HTML reports to one. For information on exporting files and HTML reports, 
see Exporting MS Project, CSV, and image files and To create a project report in HTML files. 
 
To configure FTP server settings for file exports 

1. Go to Edit > Settings. 
2. Go to the FTP tab. 
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3. Enter values as needed. 
4. Select OK. 

 

Changing fields in CSV project file exports 
You can change the task and resource fields that GanttProject includes in project files that you export 
that contain comma-separated values (CSV). Also, you can change the delimiter used between values in 
these files. For information on exporting projects in CSV files, see To export a project in a Microsoft 
Project or CSV file. 
 
To change fields in CSV project file exports 

1. Go to Edit > Settings. 
2. Go to the CSV tab. 
3. Change the settings as needed, including for the following: 

• Quote text with: Select to change the type of quotation marks used in CSV files to 
surround a value that contains a delimiter, such as a Note in a task that contains a 
comma. 

4. Select OK. 
 

Reports, imported files, and exported files 
You can create reports and export different types of files that contain information on the tasks and 
resources in a project. Also, you can import different types of files that contain similar information into 
new or existing projects. Additionally, you can import a calendar of holidays and nonwork days into a 
project. 
 
File types that GanttProject supports include Microsoft Project and comma-separated values (CSV). 
Note that many spreadsheet programs, such as Microsoft Excel, can open and save CSV files. 
 

Creating a project report 
You can create a report in a PDF file or HTML files that contains information on the tasks and resources 
in a project. This information includes values from the columns in the task and resource panels and 
images of the associated charts. 
 
To create a project report in a PDF file 

1. Go to Project > Export. 
2. Select PDF report and then select Next. 
3. Change the attributes as needed. 
4. Select OK. 

 
To create a project report in HTML files 

1. Go to Project > Export. 
2. Select HTML report and then select an HTML Theme. 
3. Select Next. 
4. Change the name and location of the primary report file if needed. 
5. To output report files to an FTP server, select Publish files on FTP. For information on 

configuring access to an FTP server, see To configure FTP server settings for file exports. 
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6. Select OK. 
 

Importing MS Project, CSV, and other files 
You can import files that contain project information, such as tasks and resources, into a new or existing 
project. The following four types of files are supported: 

• Microsoft Project 
• GanttProject 
• Comma-separated values (CSV) 
• Text 

Of these, text files are the simplest, and they just contain a list of task names, with one name per line. 
 
Also, you can import a calendar of holidays and nonwork days into a project. Calendar files must comply 
with the iCalendar standard, and files of this type have a .ics suffix. 
 
To import a Microsoft Project, CSV, GanttProject, or text file 

1. Go to Project > Import. 
2. Select the type of file to import and then select Next. 
3. Identify the file to import and select options as needed. Note that the imported file will be 

loaded into the currently open project. 
4. Select OK. 

 
To import a holiday calendar in an iCalendar file 

1. Go to Project > Import. 
2. Select iCalendar file and then select Next. 
3. Identify the file to import and then select Next. 
4. Modify calendar entries as needed. 
5. Select OK. 

 

Exporting MS Project, CSV, and image files 
You can export information in a project, including the tasks and resources in it, in a Microsoft Project file 
or a comma-separated values (CSV) file. Note that many spreadsheet programs, such as Microsoft Excel, 
can open CSV files. Also, you can export an image of the information in a project’s task or resource 
columns and the associated chart. 
 
To export a project in a Microsoft Project or CSV file 

Note: For CSV files, you can specify which task and resource fields are included. For more 
information, see To change fields in CSV project file exports. 

1. Go to Project > Export. 
2. Select Microsoft Project file or Comma-Separated Values file. 
3. Select Next. 
4. Change attributes as needed, including for the following: 

• Publish files on FTP: Select to output the project file to an FTP server. For information 
on configuring access to an FTP server, see To configure FTP server settings for file 
exports. 

5. Select OK. 
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To export an image of a project’s tasks or resources 

1. Go to the Gantt tab or Resources Chart tab. 
2. Go to Project > Export. 
3. Select Raster image file and then select a File format. 
4. Select Next. 
5. Change attributes as needed, including for the following: 

• Publish files on FTP: Select to output the image file to an FTP server. For information on 
configuring access to an FTP server, see To configure FTP server settings for file exports. 

6. Select OK. 
 

PERT charts 
You can view a program evaluation and review technique (PERT) chart of the tasks in a project to see an 
alternative visualization of them. Figure 5 below shows the first part of a PERT chart. In these charts, 
tasks on the critical path are shown in yellow, and summary tasks, which contain subtasks, are shown 
with a red border. This example was taken from the project in the file HouseBuildingSample.gan. This 
file is in the folder named GanttProject-X.Y, which is named after a specific version of GanttProject and 
is created when GanttProject is installed.  
 

 
Figure 5 PERT Chart 
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Viewing PERT chart of project tasks 
You can view a PERT chart of the tasks in a project to see an alternative visualization of them. 
 
To view a PERT chart of a project’s tasks 

• Go to View > PERT chart. 
 

Troubleshooting 
GanttProject provides two options that can help you resolve errors and recover from malfunctions. First, 
you can view information about errors in the GanttProject log file. This information may help you 
understand the cause of an error and how to resolve it. Alternatively, after a malfunction occurs, you 
can retrieve an earlier version of a project file that GanttProject automatically saved. This earlier version 
may not have been affected by the malfunction. 
 

Getting information on errors from log file 
If an error occurs in GanttProject or it displays an error message, you may be able to get additional 
information on the error in GanttProject’s log file that will help you resolve it. 
 
To get information on errors from log file 

1. Go to Help > View log. 

Note: Log entries are made chronologically, with the most recent events logged at the 
end of the file. 

2. To copy the contents of the log, select Ctrl+A and then Ctrl+C. 
3. Select Close. 
4. Using a word processor, paste the log contents in a file. 
5. Search the log for the words warning and exception to view information on warnings and errors. 

 

Recovering automatically saved file after malfunction 
As you make changes to a project file, GanttProject automatically saves instances of it so that you can 
retrieve an earlier version if needed, such as after a malfunction.  
 
To recover an automatically saved file after a malfunction 

1. Go to Help > Recover. 
2. (Optional) To retrieve to an earlier version of the project file, select Skip one or more times. 
3. Select OK. 
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